linuxsir首页 LinuxSir.Org | Linux、BSD、Solaris、Unix | 开源传万世,因有我参与欢迎您!
网站首页 | 设为首页 | 加入收藏
您所在的位置:主页 > 小企鹅新闻图书馆 >

Apache Groovy 2.4.15 发布,改进 JDK9 / 10 支持

时间:2018-03-29  来源:未知  作者:admin666

【腾讯云】0基础建站 网站模板9元起! >>>  

Groovy

Apache Groovy 2.4.15 已发布,这是 GROOVY_2_4_X 分支的维护版本,改进对 JDK9 / 10 的支持,强烈鼓励所有使用此分支旧版本的用户进行升级。

更新内容:

Bug

[GROOVY-8422] - Sql.newInstance 中的属性复制不正确

[GROOVY-8439] - @CompileStatic 无法编译泛型类的静态方法

[GROOVY-8475] - CLONE - 无法使用 “new” 关键字实例化对象

[GROOVY-8489] - CLONE -  jar 工件中的 module-info.class 无效

[GROOVY-8494] - CLONE - 从 JDK 9 中的 groovy 类调用 Stream.of 失败

[GROOVY-8514] - NullPointerException in class MissingMethodException

Improvement

[GROOVY-7779] - 从镜像系统中删除旧版本

Task

[GROOVY-8522] - 重制下载页面

更多细节可查阅发行说明

下载地址:

http://www.groovy-lang.org/download.html

友情链接